Brief Unscheduled Maintenance
Incident Report for Nalpeiron
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 07:44 PDT
Investigating
Cause by necessary server update in preparation for this weekend's server migration.

25 March 2020 12:15PM-12:18PM
Posted Mar 25, 2020 - 07:44 PDT
This incident affected: Nalpeiron Legacy Software Licensing Service V4-7 (internetactivation.com).